PDA

View Full Version : Slow bones in Subpatched objects



yaschan
07-16-2009, 09:55 PM
Maybe my settings are somehow off, but Im getting very slow bone displacements in Layout when using subpatched objects. The polygon amount doesnt seem to matter at all. Same object frozen in Modeler is lighting fast, comparing to the subpatched object. If I drop the subpatch level to zero I get the same result.
Am I missing something?

lightmann
07-16-2009, 10:10 PM
hi.check if you īve using CC(CatmullClarck subd) instead the traditional subpatches.Normally subpatches(classic real time sub D) are the lighter and effective way than CC for animation(sadly). Check if subdivision order is set to "last" or "after bones" and uncheck all kind of displacement map(normally slowdown all a bit ).

shrox
07-16-2009, 10:10 PM
Object properties, geometry tab, set the subdivision order to last. That should help.

SplineGod
07-16-2009, 11:28 PM
The subdivision order should be set to last and use lower subpatch levels when animating or use a low rez proxy character. You dont want to mix animating and deforming at the same time. Separate the two.
Also lot of weight maps, endomorphs etc will also slow down a rig.
Lots of expressions can slow down a rig.
Lowering the bounding box threshold can speed things up.
Turn off show paths can speed things up.
Turn off show keys in timeline can speed things up.
Collapse the dopetrack can speed things up.
Use the faster bones option when animating can speed things up.

yaschan
07-17-2009, 12:45 AM
That's it! I was using CC subpatches.