AH yes, the classic flicker. IS it primarily when rendering?

If so then you may have to use the "never use per-pixel shading on borders" option.

Go into your windowsblinds option and in the system information section there should be a check box at the bottom that says the above quotes "Never use per...etc"

Check that and see if your flicker is stopping.