Results 1 to 9 of 9

Thread: LW2018 Edge Rendering

  1. #1
    Registered User
    Join Date
    Feb 2018
    Location
    Rainier, WA
    Posts
    5

    LW2018 Edge Rendering

    I'm new, just got LW 2018 and am using it to create some scientific models. One of the easy ones is to overlay a grid on the Earth. I created an Earth that was .97m radius, then another sphere that was 1.0m. I added them both to Layout at the same location such that the grid overlay completely covered the Earth sphere. I then clicked the Grid sphere object, selected Properties, Edges tab and did what you see in the screenshot. I then put transparency to 100% on the grid overlay surface. I thought this would give me the effect I wanted, which was to just show the grid sphere edges, thus creating an overlay. For clarity purposes, I have not added the Earth texture to the Earth sphere yet.

    The problem is that the grid overlay should wrap around the Earth sphere, but it shows the hidden edges that should be on the other side. How do I fix this?

    Thanks.

    Rod
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	GridEdgeProblem.jpg 
Views:	59 
Size:	206.0 KB 
ID:	140074  
    Last edited by gridman144; 02-12-2018 at 09:58 AM.

  2. #2
    Why not render your Earth model with the lines on itself? Why use this second object?
    My opinions and comments do not represent those of my employer.
    www.ernestpchan.com
    www.zazzle.com/gopuggo

  3. #3
    Super Member
    Join Date
    May 2008
    Location
    Indy
    Posts
    396
    Answering your question may look smart aleck but it's not: turn transparency to zero.
    That's the best answer if you don't want to see through the sphere.

    Other than that, putting your earth texture on, and zero for transparency, ought to put it where you want.
    Robert
    Robert Wilson, MA Deaf Ed.
    Indiana Deaf School
    This e-mail may contain information protected under the Family Educational Rights and Privacy Act.

  4. #4
    TrueArt Support
    Join Date
    Feb 2003
    Location
    Poland
    Posts
    7,484
    General note.
    Attach complete scene with objects.
    It'll be easier to download and tweak to help you..
    LightWave Plugins
    Global Materials for LightWave 2018!
    Custom plugin writing. Request a quote.

  5. #5
    Registered User
    Join Date
    Feb 2018
    Location
    Rainier, WA
    Posts
    5
    Thanks for the replies. I understand what you said. However, the grid overlay in this model does not line up with the edges of the Earth sphere primitive, or rather the normal latitude/longitude lines of the Earth. The grid overlay is offset at the poles. I wanted to get this working first, then rotate the grid overlay to the proper position over the Earth.

    Perhaps edge rendering isn't the way to go.

  6. #6
    Registered User
    Join Date
    Feb 2018
    Location
    Rainier, WA
    Posts
    5
    I have attached the completed scene with objects.

    Thanks.
    Attached Files Attached Files

  7. #7
    TrueArt Support
    Join Date
    Feb 2003
    Location
    Poland
    Posts
    7,484
    You're using Principled BSDF
    But it's not working nicely when there is Smoothing turned off.
    So, turn on Smoothing and switch Grid Line sphere to Standard material.
    Also (after enabling Smoothing) consider using Other Edges instead of Sharp Edges.

    How about different approach: load sphere to Modeler, select edges, Copy, delete geometry, Paste (or paste to 2nd layer). You will have 2 point polygons network instead.
    LightWave Plugins
    Global Materials for LightWave 2018!
    Custom plugin writing. Request a quote.

  8. #8
    Registered User
    Join Date
    Feb 2018
    Location
    Rainier, WA
    Posts
    5
    Okay. Thank you very much. I'll use your suggestions.

  9. #9
    Registered User
    Join Date
    Feb 2018
    Location
    Rainier, WA
    Posts
    5
    The 2 point polygon network worked great. That was what I wanted to do in the beginning, but I didn't know the correct terminology.

    Thanks, Sensei.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •