Results 1 to 2 of 2

Thread: Problem getting de-interlacing in receiver to work

  1. #1
    Registered User
    Join Date
    Sep 2017
    Location
    London
    Posts
    6

    Problem getting de-interlacing in receiver to work

    Hi,

    I'm creating my NDI receiver as follows, because I don't want to receive interlaced video:

    Code:
    NDIlib_recv_create_t NDI_recv_create_desc;
    NDI_recv_create_desc.color_format = NDIlib_recv_color_format_e_BGRX_BGRA;
    NDI_recv_create_desc.source_to_connect_to = p_sources[0];
    NDI_recv_create_desc.allow_video_fields = false;
    NDIlib_recv_instance_t pNDI_recv = NDIlib_recv_create_v2(&NDI_recv_create_desc);
    However, it seems that this still results in me getting a frame containing two fields when I connect to an interlaced source. When I connect to the same source with the Studio Monitor application, I don't see the two fields. Am I doing something wrong when creating my receiver? Does Studio Monitor rely on this same mechanism to do de-interlacing?

    I'm running on Windows using the latest SDK (v3.0.0.12).

    Thanks!

  2. #2
    Registered User
    Join Date
    Sep 2017
    Location
    London
    Posts
    6
    Further information: when I set allow_video_fields to false, I receive frames that have their frame_format_type set to progressive, but both fields are visible in the frame.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •